Wow. Just wow. First experience with Odyssey.

I just bought Odyssey in the Fanatical sale. I'm aware of the problems in the game, but I thought for £19 I'd give it a go. I've been playing Elite for years on XBox and I've always been excited by what Odyssey claimed to be.

Let's just say my first hour hasn't been very promising.

Going through the tutorial bit I got as far as having to interact with the terminal, except it was just a black screen. Couldn't do anything with it. Closed the game and reopened it and the terminal worked.

Then got on the Cobra that picks you up. Silence all the way. Got to the port, wandered around not knowing what to do.

Tried to use a terminal, got the "opening a terminal" sound, but nothing happened apart from the fact that I couldn't move. Couldn't access anything in the terminal. By pressing random buttons I was finally able to move again, but then the game crashed.

Went back in and I was back in the tutorial on the planet, except this time there were no NPCs chasing me. Got back on the Cobra. This time the pilot actually talked to me on the way to the space port.

Got to the space port and noticed that I had 250,000 credits (the first time I got this far I had none).

At this point I've pretty much given up my £19 as a waste of money. Back to the XBox I think.

TL;DR: If you're considering getting Odyssey, be aware that even after update 8, as far as my experience is concerned, Odyssey is still pre-Alpha. If I were you I'd use that money on a game that's finished.


leave a comment

Your email address will not be published. Required fields are marked *